Clients

EzeScan WebApps is a HTML5 application that runs in a web browser.

Your browser must be a stable release version; not an alpha, beta, nightly, or development build.

While you might find EWA runs perfectly fine on older versions or other web browsers, as it is not supported our ability to assist may be limited.

  • Google Chrome: latest two versions
  • Mozilla Firefox: latest two versions
  • Apple Safari: latest two versions
  • Microsoft Edge: latest two versions 

What about IE?

In 2015, Microsoft released the Edge browser as a replacement for IE. Because of this, Internet Explorer no longer receives major updates adding the latest security and functionality that supports complex web apps like EzeScan WebApps.

We strive to make EzeScan WebApps an excellent experience for end users. The functionality that IE is missing severely limits what features we would be able to deliver by supporting such an old out dated browser.  

What are my options on a Windows Server install that only has IE?

We recommend one of the following:

  • Install Chrome or Firefox onto the server (both of which are supported by Windows Server and EWA).
  • Access EWA from another client computer using Edge or another supported browser.
  • Microsoft is making some changes to Edge which will mean it can be independently installed onto a Windows Server (No specific eta)

Server

A server needs to be set-up and configured to run EzeScanWebApps with the requirements as set-out below.

  1. IIS running on one of the following:
    1. Windows Server 2012 R2 (64-bit edition)
    2. Windows Server 2016
    3. Windows Server 2019
  2. IIS Application pool running ASP.Net 4.7.1 framework or above.
  3. IIS Needs the following role services enabled/installed:
    1. Common HTTP Features
      • Default Document
      • Directory Browsing
      • HTTP Errors
      • Static Content
    2. Health and Diagnostics
      • HTTP Logging
    3. Performance
      • Static Content Compression
    4. Security
      • Request Filtering
    5. Application Development
      • ASP.NET (Version 4.5 or above)
      • .NET Extensibility (Version 4.5 or above)
      • Application Initialization
      • ISAPI Extensions
      • ISAPI Filters
  4. Ensure that all windows updates have been installed.